This project is read-only.


Merge browse and search types more efficiently


Search was created before browse was. After looking at browsing, it becomes obvious that the 2 are very similar, and deal with the same types. It would make more sense to have everything revolving around Browsing, and having search as a part of that (ie: you can "browse" the results of a search).
The idea would be to be able to give a SearchOptions object to browse, and the returned types would be all browse-related as opposed to search related. Most of this task will simply be renaming objects currently prefixed with "search".
Closed Aug 10, 2010 at 2:24 AM by ericdunn


wrote Aug 10, 2010 at 2:24 AM

Resolved with changeset 75237.

wrote Feb 1, 2013 at 10:34 PM

wrote May 13, 2013 at 7:17 PM

wrote Mon at 6:23 AM